Linux内核ipv4/udp.c高危远程任意代码执行

Linux内核ipv4/udp.c高危远程任意代码执行

漏洞描述

Linux kernel 4.5之前的版本中的udp.c文件存在安全漏洞,Linux内核中的udp.c允许远程攻击者通过UDP流量执行任意代码,这些流量会在执行具有MSG_PEEK标志的recv系统调用时触发不安全的第二次校验和计算,远程攻击者可精心构造数据执行任意代码,进一步导致本地提权。

影响版本

Linux kernel 4.5之前的版本

漏洞等级

高危

修复建议

一些主要的Linux发行版,如Ubuntu和Debian早在今年2月份已经部署了修复后的build版本;Red Hat则表示,其Linux发行版不受该漏洞影响。谷歌方面在本月的Android安全公告中,也已经针对Android系统发布了相应的补丁。厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=197c949e7798fbf28cfadc69d9ca0c2abbf931

相关文章